IDE Bugs

From Pinguino
Jump to: navigation, search

Beta IDE

As the IDE is currently in Beta Phase there are still a few bugs.

OS X IDE x.4 revision 750

1. "Warning: File needs to be verified before uploading" occurs when "Pinguino 26J50" is chosen as the device and no hex file is produced -> you need to upgrade gpasm and gplink from v0.13.4 beta to v0.13.7 beta (later versions may work, not tested). Download gputils-0.13.7 from http://sourceforge.net/projects/gputils/files/gputils/0.13.7/ and compile (compiles cleanly under OS X 10.6.8), then copy to the rev750/macosx/p8/bin directory. [Upgrade to rev 751]

2. No output in the (F2) output window -> The text is there, but you need to highlight it with the cursor for it to become visible :-) [Upgrade to rev760]

OS X IDE x.4 revision 459

1. "File not found" when compiling -> the bin directory needs to be renamed (or linked) to bin2 [Upgrade to rev750]

2. "Warning: File needs to be verified before uploading" occurs when "Pinguino 26J50" is chosen as the device and no hex file is produced -> you need to upgrade gpasm and gplink from v0.13.4 beta to v0.13.7 beta (later versions may work, not tested). Download gputils-0.13.7 from http://sourceforge.net/projects/gputils/files/gputils/0.13.7/ and compile (compiles cleanly under OS X 10.6.8), then copy to the rev459/macosx/p8/bin directory. [Upgrade to rev751]

See further: http://forum.pinguino.cc/showthread.php?tid=3824


linux/p32/bin/../libexec/gcc/mips-elf/4.5.2/cc1: error while loading shared libraries: libmpc.so.2: wrong ELF class: ELFCLASS64

Try one of this solution depending on your Linux Distribution:


Compiler raises an error, but does not tell you where

Upgrade to Beta9-05 to solve this problem.


You hit the 'UPLOAD' button but nothing happens

You can't really say this is a bug. On the 2 computers I installed Pinguino IDE on, only one has(d) this problem. But still worth mentioning.

Solution : Find msvcp71.dll somewhere on your computer and copy/paste it to ...\pinguino betaX windows\tools\bin\bootloader\


Beta release 9-02 says when running that it is 9-01 release

Cosmetic bug - as above.


Compiler raises an error that is in a library but points a line in the user program

When compiler raises an error that is within a library file and not at the user program, it shows up the line of the user program. It should show at least in the debug window the correct name of the file where that problem was found. Also look at the stdout file in the /source folder for further information


Compiler reports "error while linking"

The compiler reports something like "error while linking C:\Users\Name\Documents\Pinguino Files\TestFile.o" and the stdout file in the /source folder ends with :-

mips-gcc.exe: Files: No such file or directory make: *** [link] Error 1

Not all directory and file names that are allowed by a particular operating system (e.g. Windows, Linux etc) are allowed by the IDE. In the above example cahnging the directory/folder name "Pinguino Files" to "Pinguino_Files" allowed the TestFile.pde to compile successfully


Beta X: Error when trying to load a compiled program onto Pinguino 32 bits (on Linux)

It's reported that library libhid0 is missing. The problem get solved when library is installed. From Ubuntu systems is recommended to use Synaptic in order to install such library.


Some future solutions

A way of automate this installation would be required.

Otherwise a note in "release notes" would be quite useful for users.